当前位置:首页 > Liunx教程 >

Apache Solr configset upload文件上传漏洞(CVE-2020-13957)

发布时间:2020-10-15 09:33:03 作者:佚名 阅读:(111)

最近看到服务器有漏洞预警提示,提示:Apache Solr configset upload文件上传漏洞(CVE-2020-13957) ,接下来吾爱编程为大家介绍一下Apache Solr configset upload文件上传漏洞修复方法,有需要的小伙伴可以参考一下:

1、漏洞描述:

    Apache Solr是一个开源的搜索服务,使用Java语言开发。Apache Solr Configset Api上传功能存在未授权漏洞。在特定条件下,攻击者可以构造特定请求,上传相关恶意文件,从而直接获取到服务器权限。阿里云应急响应中心提醒Solr用户尽快采取安全措施阻止漏洞攻击。

2、影响版本:

Apache Solr 6.6.0 - 6.6.5
Apache Solr 7.0.0 - 7.7.3
Apache Solr 8.0.0 - 8.6.2

3、安全版本:

Apache Solr 8.6.3

4、修复建议:

 升级至安全版本
 如果未使用ConfigSets API,请禁用UPLOAD命令,将系统属性: configset.upload.enabled 为 false ,可参考官方文档:https://lucene.apache.org/solr/guide/8_6/configsets-api.html。
 增加身份验证/授权,可参考官方文档:https://lucene.apache.org/solr/guide/8_6/authentication-and-authorization-plugins.html
 使用在SOLR-14663中提到的补丁程序:https://issues.apache.org/jira/browse/SOLR-146634。
 禁止Solr API 以及管理 UI 直接对公网开放。设置防火墙,以便只允许受信任的计算机和人员访问。


以上就是吾爱编程为大家介绍的关于Apache Solr configset upload文件上传漏洞修复建议,了解更多相关文章请关注吾爱编程网!


欢迎分享转载→ Apache Solr configset upload文件上传漏洞(CVE-2020-13957)

© 2015-2019 - 吾爱编程网 版权所有 苏ICP备18033726号-1关于我们 - 网站声明 - 联系我们