当前位置:首页 > 小程序 >

INSTALL_FAILED_OLDER_SDK

发布时间:2020-09-23 15:34:00 作者:佚名 阅读:(23)

今天在模拟机调试的时候,提示The application could not be installed: INSTALL_FAILED_OLDER_SDK,接下来吾爱编程为大家介绍一下INSTALL_FAILED_OLDER_SDK的解决方法,有需要的小伙伴可以参考一下:

1、错误提示:

09/23 15:26:03: Launching 'app' on android 7.1.1.
Installation did not succeed.
The application could not be installed: INSTALL_FAILED_OLDER_SDK
The application's minSdkVersion is newer than the device API level.

2、错误原因:

    The application's minSdkVersion is newer than the device API level.

    就是说apk运行所需要的最低版本高于你的真机的android版本。

3、解决方法:

    降低sdk的版本,在build.gradle文件中找到minSdkVersion,把对应的参数调小一下,再次运行查看

minSdkVersion 26

修改为

minSdkVersion 20

    ps:我的工程里面默认的是26,具体的参数根据自己的项目来修改即可


    以上就是吾爱编程为大家介绍的关于INSTALL_FAILED_OLDER_SDK的解决方法,了解更多相关文章请关注吾爱编程网!

欢迎分享转载→ INSTALL_FAILED_OLDER_SDK

© 2015-2019 - 吾爱编程网 版权所有 苏ICP备18033726号-1关于我们 - 网站声明 - 联系我们