当前位置:首页 > Liunx教程 >

RHSA-2020:2344-重要: bind 安全更新

发布时间:2020-09-16 14:46:50 作者:佚名 阅读:(143)

最近收到了服务器有漏洞的通知,提示:RHSA-2020:2344-重要: bind 安全更新,接下来吾爱编程就为大家介绍一下bind 安全更新的方法,有需要的小伙伴可以参考一下:

1、漏洞提示:

RHSA-2020:2344-重要: bind 安全更新

2、漏洞描述:

漏洞编号漏洞公告漏洞描述
 CVE-2020-8616恶意行为者故意利用这种缺乏有效限制执行次数的行为如果恶意的参与者有意利用处理引用时执行的提取数量缺乏有效限制的情况,那么通过使用特殊的精心设计的引用,会导致递归服务器在试图处理引用时发出大量的提取。这至少有两个潜在影响:递归服务器的性能可能会因为执行这些提取所需的额外工作而降低,攻击者可以利用这种行为在具有高放大系数的反射攻击中使用递归服务器作为反射器。
CVE-2020-8617使用特制的消息,攻击者可能会导致BIND服务器进入不一致状态使用特制的消息,如果攻击者知道(或成功猜测)服务器使用的TSIG密钥的名称,则攻击者可能会导致BIND服务器进入不一致状态。由于BIND默认情况下甚至会在其配置未使用的本地服务器上配置本地会话密钥,因此几乎所有当前的BIND服务器都容易受到攻击。在2018年3月及之后的BIND版本中,tsig.c中的断言检查可检测到这种不一致的状态并故意退出。在引入检查之前,服务器将继续以不一致的状态运行,从而可能导致有害的结果。

3、影响说明:

软件:bind-license 9.11.4-9.P2.el7
命中:bind-license version less than 32:9.11.4-16.P2.el7_8.6
路径:/usr/share/licenses/bind-license-9.11.4
软件:bind-libs-lite 9.11.4-9.P2.el7
命中:bind-libs-lite version less than 32:9.11.4-16.P2.el7_8.6
路径:/usr/lib64/libdns.so.1102
软件:bind-export-libs 9.11.4-9.P2.el7
命中:bind-export-libs version less than 32:9.11.4-16.P2.el7_8.6
路径:/etc/ld.so.conf.d/bind-export-x86_64.conf

4、解决方法:

yum update bind-license
yum update bind-libs-lite
yum update bind-export-libs

5、重启验证:

reboot

以上就是吾爱编程为大家介绍的关于RHSA-2020:2344-重要: bind 安全更新的解决方法,了解更多相关文章请关注吾爱编程网!

欢迎分享转载→ RHSA-2020:2344-重要: bind 安全更新

© 2015-2019 - 吾爱编程网 版权所有 苏ICP备18033726号-1关于我们 - 网站声明 - 联系我们