当前位置:首页 > Python >

You are using pip version 19.3.1; however, version 20.1.1 is available.

发布时间:2020-07-21 14:15:50 作者:佚名 阅读:(35)

今天在安装pip的numpy模块的时候提示You are using pip version 19.3.1; however, version 20.1.1 is available.,错误提示的意思是当前的pip版本太低,接下来吾爱编程为大家介绍一下pip版本升级,有需要的小伙伴可以参考一下:

1、错误提示:

  File "d:\program files (x86)\python\python37\lib\site-packages\pip\_vendor\url
lib3\response.py", line 430, in _error_catcher
    raise ReadTimeoutError(self._pool, None, "Read timed out.")
pip._vendor.urllib3.exceptions.ReadTimeoutError: HTTPSConnectionPool(host='files
.pythonhosted.org', port=443): Read timed out.
WARNING: You are using pip version 19.3.1; however, version 20.1.1 is available.

You should consider upgrading via the 'python -m pip install --upgrade pip' comm
and.

提示需要升级到本部20.1.1

2、升级方法:

    把命令行窗口切换到Python的安装目录,然后执行升级命令

python -m pip install --upgrade pip

    安装成功会有如下提示:

Installing collected packages: pip
  Found existing installation: pip 19.3.1
    Uninstalling pip-19.3.1:
      Successfully uninstalled pip-19.3.1
Successfully installed pip-20.1.1

3、查看版本:

pip -V


以上就是吾爱编程为大家介绍的关于You are using pip version 19.3.1; however, version 20.1.1 is available的解决方法,了解更多相关文章请关注吾爱编程网!

欢迎分享转载→ You are using pip version 19.3.1; however, version 20.1.1 is available.

© 2015-2019 - 吾爱编程网 版权所有 苏ICP备18033726号-1关于我们 - 网站声明 - 联系我们