当前位置:首页 > Liunx教程 >

composer Updating dependencies (including require-dev)

发布时间:2020-03-30 14:43:01 作者:佚名 阅读:(1304)

今天看到了一个不错的网站源码,git下载之后还需要composer更新依赖包,更新的时候一直卡在Updating dependencies (including require-dev),没有任何反应了,接下来吾爱编程就为大家介绍一下解决方法,有需要的小伙伴可以参考一下:

1、提示:

[[email protected] wizard]# composer install --prefer-dist --ignore-platform-reqs
Loading composer repositories with package information
Updating dependencies (including require-dev)

2、错误原因:

因为我们常用的一些资源都是github上面的,是在国外的,而国外的网站连接速度很慢,并且随时可能被“墙”甚至“不存在”。

3、解决方法:

    (1)、我们可以在omposer.json所在目录也就是我们所说的网站的根目录,执行:

composer config repo.packagist composer https://packagist.phpcomposer.com

    这个时候我们就可以在我们的omposer.json文件底部看到多了:

"repositories": {
    "packagist": {
        "type": "composer",
        "url": "https://packagist.phpcomposer.com"
    }
}

    (2)、再去执行我们的命令,即可:

composer install --prefer-dist --ignore-platform-reqs

4、修改compose镜像源生效:

    (1)、针对当前项目生效:

composer config repo.packagist composer  https://mirrors.aliyun.com/composer/
# 如果需要取消当前项目配置,可以执行下面的
composer config --unset repos.packagist

    (2)、针对全局生效:

composer config -g repo.packagist composer https://mirrors.aliyun.com/composer/
# 如果需要取消全局配置,执行以下命令即可
composer config -g --unset repos.packagist


以上就是吾爱编程为大家介绍的关于composer Updating dependencies (including require-dev)的解决方法,了解更多相关文章请关注吾爱编程网!

欢迎分享转载→ composer Updating dependencies (including require-dev)

© 2015-2019 - 吾爱编程网 版权所有 苏ICP备18033726号-1关于我们 - 网站声明 - 联系我们